Get in touch
Back
Maintenance

Scheduled Maintenance for Upgrades

Completed 30 Oct at 07:30pm CEST.

https://hosting.cybertap.ch/ Root Server response Time DNS Service World DNS SMTP on cybertap.ch IMAP on cybertap.ch https://cybertap.ch https://dev.lwlx.xyz
Completed

Maintenance completed

Posted 30 Oct at 07:30pm CEST.
Started

Some Services could be unavailable during this time.

Posted 30 Oct at 03:15pm CEST.